# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/'{%\s*url '([^']*)'%}/'\1'/gm;t' <<< "<a class='login-password-forget' tabindex='1' href='{% url 'account:pwdreset'%}>Forgot your password?</a>"