import Foundation
let pattern = #"'{%\s*url '([^']*)'%}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"<a class='login-password-forget' tabindex='1' href='{% url 'account:pwdreset'%}>Forgot your password?</a>"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"'\1'"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)