$re = '/\'{%\s*url \'([^\']*)\'%}/m';
$str = '<a class=\'login-password-forget\' tabindex=\'1\' href=\'{% url \'account:pwdreset\'%}>Forgot your password?</a>';
$subst = "'\1'";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;