use strict;
my $str = '<a class=\'login-password-forget\' tabindex=\'1\' href=\'{% url \'account:pwdreset\'%}>Forgot your password?</a>';
my $regex = qr/'{%\s*url '([^']*)'%}/mp;
my $subst = '\'\\1\'';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";