using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"'{%\s*url '([^']*)'%}";
string substitution = @"'\1'";
string input = @"<a class='login-password-forget' tabindex='1' href='{% url 'account:pwdreset'%}>Forgot your password?</a>";
RegexOptions options = RegexOptions.Multiline;
Regex regex = new Regex(pattern, options);
string result = regex.Replace(input, substitution);
}
}