package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m).*?(\w+)$`)
var str = `Tommy Hilfiger Men Teal Blue Analogue Watch TH1791293_BBD`
var substitution = "$1"
fmt.Println(re.ReplaceAllString(str, substitution))
}