re = /.*?(\w+)$/m
str = 'Tommy Hilfiger Men Teal Blue Analogue Watch TH1791293_BBD'
subst = '$1'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result