use strict;
my $str = 'Tommy Hilfiger Men Teal Blue Analogue Watch TH1791293_BBD';
my $regex = qr/.*?(\w+)$/mp;
my $subst = '$1';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";