#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?!.*https?[^\s]+.*).*$"
Local $sString = "Sorry, we are closed today. Visit our website tomorrow at https://www.google.com. Thank you and have a nice day!" & @CRLF & _
"" & @CRLF & _
"Sorry, we are closed today. Visit our website tomorrow at. Thank you and have a nice day!" & @CRLF & _
"" & @CRLF & _
"Sorry, we are closed today. Visit our website tomorrow at https://www.goog. Thank you and have a nice day!" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")