$re = '/^(?!.*https?[^\s]+.*).*$/m';
$str = 'Sorry, we are closed today. Visit our website tomorrow at https://www.google.com. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at https://www.goog. Thank you and have a nice day!
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);