using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^(?!.*https?[^\s]+.*).*$";
string input = @"Sorry, we are closed today. Visit our website tomorrow at https://www.google.com. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at https://www.goog. Thank you and have a nice day!
";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}