const regex = /^(?!.*https?[^\s]+.*).*$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?!.*https?[^\\s]+.*).*$', 'gm')
const str = `Sorry, we are closed today. Visit our website tomorrow at https://www.google.com. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at https://www.goog. Thank you and have a nice day!
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}