re = /^(?!.*https?[^\s]+.*).*$/m
str = 'Sorry, we are closed today. Visit our website tomorrow at https://www.google.com. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at. Thank you and have a nice day!
Sorry, we are closed today. Visit our website tomorrow at https://www.goog. Thank you and have a nice day!
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end