package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(")([^"]*)(")|(')([^']*)(')`)
var str = `"com s'ha fet?" 'El "milor" que es pot!'`
var substitution = "\2\n\5"
fmt.Println(re.ReplaceAllString(str, substitution))
}