re = /(")([^"]*)(")|(')([^']*)(')/
str = '"com s\'ha fet?" \'El "milor" que es pot!\''
subst = '\\2\\n\\5'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result