import re
regex = re.compile(r"(\")([^\"]*)(\")|(')([^']*)(')")
test_str = "\"com s'ha fet?\" 'El \"milor\" que es pot!'"
subst = "\\2\\n\\5"
result = regex.sub(subst, test_str)
if result:
print(result)