import Foundation
let pattern = #"(")([^"]*)(")|(')([^']*)(')"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #""com s'ha fet?" 'El "milor" que es pot!'"#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"\2\n\5"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)