using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"POST\s[^\/]+\/user\/(?<userid>[^\/]+)\/def\/(?<defid>[^\/]+)\/\S+";
string input = @"POST {base_url}/user/{user_id}/def/{def_id}/xyz
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}