re = /POST\s[^\/]+\/user\/(?<userid>[^\/]+)\/def\/(?<defid>[^\/]+)\/\S+/
str = 'POST {base_url}/user/{user_id}/def/{def_id}/xyz
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end