import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "POST\\s[^\\/]+\\/user\\/(?<userid>[^\\/]+)\\/def\\/(?<defid>[^\\/]+)\\/\\S+";
final String string = "POST {base_url}/user/{user_id}/def/{def_id}/xyz\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}