package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`POST\s[^\/]+\/user\/(?<userid>[^\/]+)\/def\/(?<defid>[^\/]+)\/\S+`)
var str = `POST {base_url}/user/{user_id}/def/{def_id}/xyz
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}