const regex = /POST\s[^\/]+\/user\/(?<userid>[^\/]+)\/def\/(?<defid>[^\/]+)\/\S+/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('POST\\s[^\\\/]+\\\/user\\\/(?<userid>[^\\\/]+)\\\/def\\\/(?<defid>[^\\\/]+)\\\/\\S+', '')
const str = `POST {base_url}/user/{user_id}/def/{def_id}/xyz
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}