#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)^" & @CRLF & _
"(?= (\d+) \1+ (\d*) $ )" & @CRLF & _
"(?<pattern> \d+? ) \3+" & @CRLF & _
"(?! .+ \2 $)" & @CRLF & _
"(?= (?<trailing> \d* ) )"
Local $sString = "14285714285714" & @CRLF & _
"7575757" & @CRLF & _
"55555555" & @CRLF & _
"55555556" & @CRLF & _
"15551555" & @CRLF & _
"55515551"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")