// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mx)^
(?= (\d+) \1+ (\d*) $ )
(?<pattern> \d+? ) \3+
(?! .+ \2 $)
(?= (?<trailing> \d* ) )").unwrap();
let string = "14285714285714
7575757
55555555
55555556
15551555
55515551";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}