const regex = /^
(?= (\d+) \1+ (\d*) $ )
(?<pattern> \d+? ) \3+
(?! .+ \2 $)
(?= (?<trailing> \d* ) )/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^
(?= (\\d+) \\1+ (\\d*) $ )
(?<pattern> \\d+? ) \\3+
(?! .+ \\2 $)
(?= (?<trailing> \\d* ) )', 'gm')
const str = `14285714285714
7575757
55555555
55555556
15551555
55515551`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}