package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^
(?= (\d+) \1+ (\d*) $ )
(?<pattern> \d+? ) \3+
(?! .+ \2 $)
(?= (?<trailing> \d* ) )`)
var str = `14285714285714
7575757
55555555
55555556
15551555
55515551`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}