import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<span id=\"organization\">(?<company_name>[^<]+)<\\/span><\\/p>\\n\\s*(?<designation>[^\\n]+)\\n\\s*<p>(?<date>[^\\n]+)";
final String string = "<h5>Work Experience</h5>\n"
+ " <p><span id=\"organization\">Company Name 1</span></p>\n"
+ " Designation 1\n"
+ " <p>Date 1\n"
+ " </p>\n"
+ " <ul>\n"
+ " <li>Some text 1</li>\n"
+ " </ul>\n"
+ " <p><span id=\"organization\">Company Name 2</span></p>\n"
+ " Designation 2\n"
+ " <p>Date 2\n"
+ " </p>\n"
+ " <ul>\n"
+ " <li>Some text 2</li>\n"
+ " </ul>\n"
+ " <p><span id=\"organization\">Company Name 3</span></p>\n"
+ " Designation 3\n"
+ " <p>Date 3\n"
+ " </p>\n"
+ " <ul>\n"
+ " <li>Some text 3</li>\n"
+ " </ul></div>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}