$re = '/<span id="organization">(?<company_name>[^<]+)<\/span><\/p>\n\s*(?<designation>[^\n]+)\n\s*<p>(?<date>[^\n]+)/';
$str = '<h5>Work Experience</h5>
<p><span id="organization">Company Name 1</span></p>
Designation 1
<p>Date 1
</p>
<ul>
<li>Some text 1</li>
</ul>
<p><span id="organization">Company Name 2</span></p>
Designation 2
<p>Date 2
</p>
<ul>
<li>Some text 2</li>
</ul>
<p><span id="organization">Company Name 3</span></p>
Designation 3
<p>Date 3
</p>
<ul>
<li>Some text 3</li>
</ul></div>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);