const regex = /<span id="organization">(?<company_name>[^<]+)<\/span><\/p>\n\s*(?<designation>[^\n]+)\n\s*<p>(?<date>[^\n]+)/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<span id="organization">(?<company_name>[^<]+)<\\\/span><\\\/p>\\n\\s*(?<designation>[^\\n]+)\\n\\s*<p>(?<date>[^\\n]+)', 'g')
const str = `<h5>Work Experience</h5>
<p><span id="organization">Company Name 1</span></p>
Designation 1
<p>Date 1
</p>
<ul>
<li>Some text 1</li>
</ul>
<p><span id="organization">Company Name 2</span></p>
Designation 2
<p>Date 2
</p>
<ul>
<li>Some text 2</li>
</ul>
<p><span id="organization">Company Name 3</span></p>
Designation 3
<p>Date 3
</p>
<ul>
<li>Some text 3</li>
</ul></div>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}