import re
regex = re.compile(r"<span id=\"organization\">(?<company_name>[^<]+)<\/span><\/p>\n\s*(?<designation>[^\n]+)\n\s*<p>(?<date>[^\n]+)")
test_str = ("<h5>Work Experience</h5>\n"
" <p><span id=\"organization\">Company Name 1</span></p>\n"
" Designation 1\n"
" <p>Date 1\n"
" </p>\n"
" <ul>\n"
" <li>Some text 1</li>\n"
" </ul>\n"
" <p><span id=\"organization\">Company Name 2</span></p>\n"
" Designation 2\n"
" <p>Date 2\n"
" </p>\n"
" <ul>\n"
" <li>Some text 2</li>\n"
" </ul>\n"
" <p><span id=\"organization\">Company Name 3</span></p>\n"
" Designation 3\n"
" <p>Date 3\n"
" </p>\n"
" <ul>\n"
" <li>Some text 3</li>\n"
" </ul></div>")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")