import Foundation
let pattern = #"<span id="organization">(?<company_name>[^<]+)<\/span><\/p>\n\s*(?<designation>[^\n]+)\n\s*<p>(?<date>[^\n]+)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
<h5>Work Experience</h5>
<p><span id="organization">Company Name 1</span></p>
Designation 1
<p>Date 1
</p>
<ul>
<li>Some text 1</li>
</ul>
<p><span id="organization">Company Name 2</span></p>
Designation 2
<p>Date 2
</p>
<ul>
<li>Some text 2</li>
</ul>
<p><span id="organization">Company Name 3</span></p>
Designation 3
<p>Date 3
</p>
<ul>
<li>Some text 3</li>
</ul></div>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)