# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(?:http?:\\/\\/|https?:\\/\\/)?(?:www\.)?dribbble\.com\\/(?:\\/*)([\w\-\.]*)//gm;t' <<< "https://www.dribbble.com/epiccoders?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
http://dribbble.com/name/"