use strict;
my $str = 'https://www.dribbble.com/epiccoders?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
http://dribbble.com/name/';
my $regex = qr/(?:http?:\/\/|https?:\/\/)?(?:www\.)?dribbble\.com\/(?:\/*)([\w\-\.]*)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";