re = /(?:http?:\/\/|https?:\/\/)?(?:www\.)?dribbble\.com\/(?:\/*)([\w\-\.]*)/m
str = 'https://www.dribbble.com/epiccoders?id=107523146&authType=name&authToken=A2nj&trk=nmp_pymk_name
http://dribbble.com/name/'
subst = ''
result = str.gsub(re, subst)
# Print the result of the substitution
puts result