#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\.\d\."
Local $sString = "string2.string = no good" & @CRLF & _
"" & @CRLF & _
"string.1.string = match" & @CRLF & _
"" & @CRLF & _
"strstr.9.strstr = match" & @CRLF & _
"" & @CRLF & _
"str3.-3.str = no good"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")