using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\.\d\.";
string input = @"string2.string = no good
string.1.string = match
strstr.9.strstr = match
str3.-3.str = no good";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}