package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`\.\d\.`)
var str = `string2.string = no good
string.1.string = match
strstr.9.strstr = match
str3.-3.str = no good`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}