re = /\.\d\./
str = 'string2.string = no good
string.1.string = match
strstr.9.strstr = match
str3.-3.str = no good'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end