$re = '/\.\d\./';
$str = 'string2.string = no good
string.1.string = match
strstr.9.strstr = match
str3.-3.str = no good';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);