#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?x)(\d){1,2} \. (\d){1,2} \. ( \d{2} | \d{4} ) \b"
Local $sString = "Folgende Zeichenketten sollten z.B. erkannt werden:" & @CRLF & _
"• 03.05.1992 1.9.1988 03.05.95" & @CRLF & _
"" & @CRLF & _
"Folgende Zeichenketten sollten nicht erkannt werden:" & @CRLF & _
"• 03/04/1995 192.168.2.1 3.05.195 05.1992" & @CRLF & _
"" & @CRLF & _
"Sonderpunkte gibt es, wenn Sie den Wertebereich von Tag und Monat erfolgreich" & @CRLF & _
"überprüfen." & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")