use strict;
my $str = 'Folgende Zeichenketten sollten z.B. erkannt werden:
• 03.05.1992 1.9.1988 03.05.95
Folgende Zeichenketten sollten nicht erkannt werden:
• 03/04/1995 192.168.2.1 3.05.195 05.1992
Sonderpunkte gibt es, wenn Sie den Wertebereich von Tag und Monat erfolgreich
überprüfen.
';
my $regex = qr/(\d){1,2} \. (\d){1,2} \. ( \d{2} | \d{4} ) \b/xp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}