using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d){1,2} \. (\d){1,2} \. ( \d{2} | \d{4} ) \b";
string input = @"Folgende Zeichenketten sollten z.B. erkannt werden:
• 03.05.1992 1.9.1988 03.05.95
Folgende Zeichenketten sollten nicht erkannt werden:
• 03/04/1995 192.168.2.1 3.05.195 05.1992
Sonderpunkte gibt es, wenn Sie den Wertebereich von Tag und Monat erfolgreich
überprüfen.
";
RegexOptions options = RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}