package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(\d){1,2} \. (\d){1,2} \. ( \d{2} | \d{4} ) \b`)
var str = `Folgende Zeichenketten sollten z.B. erkannt werden:
• 03.05.1992 1.9.1988 03.05.95
Folgende Zeichenketten sollten nicht erkannt werden:
• 03/04/1995 192.168.2.1 3.05.195 05.1992
Sonderpunkte gibt es, wenn Sie den Wertebereich von Tag und Monat erfolgreich
überprüfen.
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}