// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?x)(\d){1,2} \. (\d){1,2} \. ( \d{2} | \d{4} ) \b").unwrap();
let string = "Folgende Zeichenketten sollten z.B. erkannt werden:
• 03.05.1992 1.9.1988 03.05.95
Folgende Zeichenketten sollten nicht erkannt werden:
• 03/04/1995 192.168.2.1 3.05.195 05.1992
Sonderpunkte gibt es, wenn Sie den Wertebereich von Tag und Monat erfolgreich
überprüfen.
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}