# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/\\((\w+\s+)+\w+)\\/\\"$1"\\/g;t' <<< "cat \"food\" | c:\Program Files\nodejs\node app.exe
c:\Program Files\nodejs\node.exe
cat \"c:\Program Files\nodejs\node.exe\" | pipe | c:\apps and stuff\node.exe"