use strict;
my $str = 'cat "food" | c:\\Program Files\\nodejs\\node app.exe
c:\\Program Files\\nodejs\\node.exe
cat "c:\\Program Files\\nodejs\\node.exe" | pipe | c:\\apps and stuff\\node.exe';
my $regex = qr/\\((\w+\s+)+\w+)\\/p;
my $subst = '\\\\"$1"\\\\';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";