using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"\\((\w+\s+)+\w+)\\";
string substitution = @"\\""$1""\\";
string input = @"cat ""food"" | c:\Program Files\nodejs\node app.exe
c:\Program Files\nodejs\node.exe
cat ""c:\Program Files\nodejs\node.exe"" | pipe | c:\apps and stuff\node.exe";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution);
}
}