// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"\\((\w+\s+)+\w+)\\").unwrap();
let string = "cat \"food\" | c:\\Program Files\\nodejs\\node app.exe
c:\\Program Files\\nodejs\\node.exe
cat \"c:\\Program Files\\nodejs\\node.exe\" | pipe | c:\\apps and stuff\\node.exe";
let substitution = "\\\\\"$1\"\\\\";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}