re = /\\((\w+\s+)+\w+)\\/
str = 'cat "food" | c:\\Program Files\\nodejs\\node app.exe
c:\\Program Files\\nodejs\\node.exe
cat "c:\\Program Files\\nodejs\\node.exe" | pipe | c:\\apps and stuff\\node.exe'
subst = '\\\\"$1"\\\\'
result = str.gsub(re, subst)
# Print the result of the substitution
puts result