using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*(([a-z0-9]+|([a-z0-9]+[-]+[a-z0-9]+))[.])+[ \t]*+\(+\d{10,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*+\d{3,10}+[ \t]*\)";
string input = @"ns1.domain.com.net.xxx.any.tld. mail.ns1.any.com.ge. (2014061613 3600 600 604800 1800 )";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}